Older wxWidgets 3.0.0 Packages and Repositories


This page is an archive of information about older wx binaries, and binaries for older distro versions. For the latest versions, see WxWidgets30Binaries.

The latest versions of CodeLite require wxWidgets >=3.0.0, which isn't easily available as binaries. I've therefore built packages for the commonest distros.
The packages should support wxMediaCtrl, and also wxWebView for those distro versions that can supply its dependencies i.e. not ubuntu maverick or lucid, nor debian squeeze.

Note that the wx3.0 links on this page point to repos and binaries patched with the mousewheel scroll fix.
If you prefer to use the pure, original wx3.0, see WxWidgets30BinariesOriginal.

They are signed with the CodeLite public key so, if you haven't done so before, you should tell apt or rpm about this by doing as superuser (su or sudo depending on your distro):

 apt-key adv --fetch-keys http://repos.codelite.org/CodeLite.asc

or

rpm --import http://repos.codelite.org/CodeLite.asc

Ubuntu and debian

If you use a debian-based distro there are the following wxWidgets repositories available:

wxWidgets Repositories
 RepositoryAvailable VersionsComponent
debianhttp://repos.codelite.org/wx3.0/debian/squeeze wheezylibs
ubuntu <= 13.10 (saucy)http://repos.codelite.org/wx3.0/ubuntu/precise quantal raring saucyuniverse
ubuntu 14.04 (trusty)http://repos.codelite.org/wx3.0trusty/trustyuniverse

The ubuntu ones should also work on other *buntus, and on derivatives e.g. Mint.

Now let apt know that the repository exits. If you use an apt front-end e.g. synaptic, tell it to Add a repository, using as data the appropriate entry in the table above.

If you do things by hand, add the appropriate url to /etc/apt/sources.list.
Become superuser and either use a text editor to edit /etc/apt/sources.list, adding a line similar to:

deb http://repos.codelite.org/wx3.0/debian/ wheezy libs

or, in a terminal, do:

sudo apt-add-repository 'deb http://repos.codelite.org/wx3.0/ubuntu/ saucy universe'

The line to add is different for different distros/versions; choose the appropriate one:

wxWidgets Repositories
Distro/releaseLine to append
debian squeezedeb http://repos.codelite.org/wx3.0/debian/ squeeze libs
debian wheezydeb http://repos.codelite.org/wx3.0/debian/ wheezy libs
ubuntu precisedeb http://repos.codelite.org/wx3.0/ubuntu/ precise universe
ubuntu quantaldeb http://repos.codelite.org/wx3.0/ubuntu/ quantal universe
ubuntu raringdeb http://repos.codelite.org/wx3.0/ubuntu/ raring universe
ubuntu saucydeb http://repos.codelite.org/wx3.0/ubuntu/ saucy universe
  
ubuntu trustydeb http://repos.codelite.org/wx3.0trusty/ trusty universe

You then need update the repositories. In synaptic, click the Reload button. If you're doing things by hand, do:

 apt-get update

and then depends on your Debian/Ubuntu do:

ubuntu 14.04 trusty

There are official wx3.0.0 trusty packages in the distro repos. However these don't contain the mousewheel fix mentioned above, so I've rebuilt them to incorporate that fix, and incremented the version number to 3.0.0-3. This means that, if you try to install them as above, they'll be seen as an updated version of the official ones, so they shouldn't affect any wx programs that depend on the official wx3 (except to make the mousewheel work properly).

For technical reasons, they won't fit into the standard 'unofficial' wx3.0 ubuntu repo. Instead they have a repo of their own, called wx3.0trusty. The names of the packages are different, so you'll need to do:

 apt-get install libwxbase3.0-0 libwxbase3.0-dev libwxgtk3.0-0 libwxgtk3.0-dev wx3.0-headers wx-common libwxgtk-media3.0-0 libwxgtk-media3.0-dev libwxbase3.0-0-dbg libwxgtk3.0-0-dbg libwxgtk-media3.0-0-dbg wx3.0-i18n wx3.0-examples

Again, only the first 6 are required.

For others (Ubuntu/Debian)

 apt-get install libwxbase3.0-0-unofficial libwxbase3.0-dev libwxgtk3.0-0-unofficial libwxgtk3.0-dev wx3.0-headers wx-common libwxbase3.0-dbg libwxgtk3.0-dbg wx3.0-i18n wx3.0-examples wx3.0-doc

The first 6 of those are required; the others optional (and of decreasing importance).

wx-common and wx3.0-i18n will conflict with the distro's wx2.8 equivalents. That is unlikely to matter too much; but wx-common contains wxrc so, if you use this, be aware that there may be differences after upgrading.

Fedora and openSUSE

There are currently rpms available for fedora 18 19 and 20, and openSUSE 12.3 and 13.1.

wxWidgets rpms
DistroReleasei386x86_64
fedora18wx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18nwx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18n
fedora19wx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18nwx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18n
fedora20wx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18nwx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18n
openSUSE12.3wx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18nwx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18n
openSUSE13.1wx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18nwx-base-unicode wx-base-unicode-devel wx-gtk2-unicode wx-gtk2-unicode-devel wx-gtk2-unicode-gl wx-i18n

There are also source rpms for Fedora and openSUSE.
Either download the required rpms and install them as usual, or download and install in one step; e.g.

rpm -Uvh http://repos.codelite.org/wx3.0/wx3.0-packages/fedora/3.0.0/20/wx-base-unicode-devel-3.0.0-2.i686.rpm

These rpms contain both shared and static builds. Note that they conflict with the wx2.8 devel ones.

Edit - History - Print - Recent Changes - Search
Page last modified on January 27, 2016, at 05:11 PM