Page 1 of 1

Cannot get CodeLite to work on Windows

Posted: Thu Jan 07, 2021 1:38 pm
by woistmeinauto
I pick c++ and it says I need to download mingw, then it redirects me to this link:

First off, this is not the correct link, it makes you download chunks of binaries or something.

It should be this one ... e/download

Anyway I found the correct link and installed on the C:\mingw folder I created.
After the scan, it finds MinGW alright but when I click build absolutely nothing happens. It shows up on build options and it's the only build option there anyway.

I created a workspace on Documents/CodeLite
I tried also creating a project, regardless it doesn't seem to work.

The file I'm trying to compile is a hello word I just created to test.

No error message pops up.

I'll now try other compilers but i need to say this is awful.

Re: Cannot get CodeLite to work on Windows

Posted: Mon Jan 11, 2021 12:57 pm
by woistmeinauto
No matter what I tried I got all sorts of errors.
It's a shame back in the day I used this program and it was pretty good.
I installed geany and it worked immediately. Didn't ask me any questions, didn't require me to bother with workspace to compile a single file.