[SOLVED] CL 6.1 on Ubuntu 14.10, loses many keystrokes

CodeLite installation/troubleshooting forum

[SOLVED] CL 6.1 on Ubuntu 14.10, loses many keystrokes

Postby piebru57 » Sat Nov 15, 2014 1:27 pm

Hi, all was OK with CL up to Ubuntu 13.10, but after reinstalling my PC with Ubuntu 14.10 and CodeLite 6.1, the editor is unusable because about 30% of keystrokes are lost while typing.
It happens only within CodeLite, while typing code or comments, and even in the preferences inputs.
Any hint?
Thanks,
Piero
Last edited by piebru57 on Fri Nov 21, 2014 1:53 pm, edited 1 time in total.
piebru57
CodeLite Enthusiast
 
Posts: 12
Joined: Sat Nov 15, 2014 1:16 pm

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby eranif » Sat Nov 15, 2014 2:06 pm

This sounds like a keyboard layout problem with wxWidgets.
Are you using some non standard keyboard layout?

Eran
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
 
Posts: 5632
Joined: Wed Feb 06, 2008 9:29 pm

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby piebru57 » Sat Nov 15, 2014 4:48 pm

Hi Eran, I'm using the standard Ubuntu italian keyboard layout, the system language is US English.
The system is almost fresh install, I did not mess a yet with OS components.
libwxbase3 and libwxgtk3 are at version 3.0.1-3
I'm trying to simulate also on a stock live Ubuntu 14.10, but after update+upgrade it refuses to install codelite 6 because libwxbase3 and libwxgtk3 are "not installable".
Thanks,
Piero
piebru57
CodeLite Enthusiast
 
Posts: 12
Joined: Sat Nov 15, 2014 1:16 pm

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby DavidGH » Sat Nov 15, 2014 5:49 pm

Hi,
it refuses to install codelite 6 because libwxbase3 and libwxgtk3 are "not installable".

That sounds like a packaging error: CodeLite contains a copy of those libs, so they aren't true dependencies.

Try downloading the CodeLite deb, and then doing: sudo dpkg --ignore-depends=codelite -i /path/to/the/codelite/deb

Regards,

David
DavidGH
CodeLite Plugin
 
Posts: 476
Joined: Wed Sep 03, 2008 7:26 pm

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby piebru57 » Sat Nov 15, 2014 8:55 pm

The keystroke loss problem persists after "sudo apt-get purge codelite" (was installed as indicated on http://codelite.org/LiteEditor/Repositories), and then sudo dpkg --ignore-depends=codelite -i codelite_6.1-1.utopic_amd64.deb

The packaging issue seems confirmed, although CL starts correctly:
Code: Select all
user1@U1L-Z500:~/Downloads$ sudo dpkg --ignore-depends=codelite -i codelite_6.1-1.utopic_amd64.deb
(Reading database ... 221878 files and directories currently installed.)
Preparing to unpack codelite_6.1-1.utopic_amd64.deb ...
Unpacking codelite (6.1-1.utopic) over (6.1-1.utopic) ...
dpkg: dependency problems prevent configuration of codelite:
 codelite depends on libwebkitgtk-1.0-0 (>= 1.3.10); however:
  Package libwebkitgtk-1.0-0:amd64 is not installed.
 codelite depends on libwxbase3.0-0 (>= 3.0.1); however:
  Package libwxbase3.0-0:amd64 is not installed.
 codelite depends on libwxgtk3.0-0 (>= 3.0.1); however:
  Package libwxgtk3.0-0:amd64 is not installed.
 codelite depends on libedit-dev; however:
  Package libedit-dev is not installed.

dpkg: error processing package codelite (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu2) ...
Processing triggers for bamfdaemon (0.5.1+14.10.20140925-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.55ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for man-db (2.7.0.2-2) ...
Processing triggers for menu (2.1.47ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 codelite
user1@U1L-Z500:~/Downloads$


The same Ubuntu 14.04, stock live instead of installed, is not affected by installing CL using dpkg to circumvent the depends issue.

On this PC (Lenovo Z500) CL worked fine until some weeks ago with Ubuntu 13.10.

Thanks,
Piero
piebru57
CodeLite Enthusiast
 
Posts: 12
Joined: Sat Nov 15, 2014 1:16 pm

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby DavidGH » Sun Nov 16, 2014 12:05 am

The keystroke loss problem persists

I can't make it happen on 14.10 here.

Is there a way that you can suggest to help us reproduce this? For example, what happens if you temporarily delete your ~/.codelite dir (so that you start with everything as default) or else run CodeLite with the -c /path/to/somewhere/else/ option that will have the same effect; then create a new workspace and gui project, open one if its files and start typing. Does it immediately happen?

Also, is there anything unusual about your installation? Which DE are you using? Are there any other processes using all your cpu cycles when it happens?
DavidGH
CodeLite Plugin
 
Posts: 476
Joined: Wed Sep 03, 2008 7:26 pm

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby Alix » Sun Nov 16, 2014 1:09 am

Hi, I experiment exactly the same problem, lots of keystrokes dropped by Codelite.

My installation is a fresh install of Ubuntu 14.10 on a brand new desktop computer, with Codelite 6.1 installed from the Codelite apt repository. After deleting the ~/.codelite directory and starting codelite:

1) Opening a new text file and typing: no problems.
2) Creating a new workspace (and nothing more), then opening a new text file an typing: lots of keystokes are dropped.
3) Closing the workspace, then opening a new text file and typing: the problem disappears.

During the whole test, none of the processor cores showed more than 20% CPU usage, and the memory usage was below 25% (even with lots of processes running in the background). To my best knowledge, I have not yet encountered the problem with any other application. Also, typing very slowing (waiting one or two seconds between keystrokes) does not solve the problem.

If there is any other test I can perform, I would be glad to help.

Thank you very much for any help or advice.
Alix
CodeLite Curious
 
Posts: 8
Joined: Sun Nov 16, 2014 12:54 am

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby DavidGH » Sun Nov 16, 2014 1:41 am

Hi, I experiment exactly the same problem, lots of keystrokes dropped by Codelite.

Which keyboard layout, which locale do you have?

It's strange. I've just tested ubuntu 14.10 in a vbox guest: still no problem.

I've tested now on lxde and unity. Which DE do each of you use?
DavidGH
CodeLite Plugin
 
Posts: 476
Joined: Wed Sep 03, 2008 7:26 pm

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby Alix » Sun Nov 16, 2014 1:58 am

Thanks David for the super-fast response. Wow!

My keyboard is a Logitech S520 wireless keyboard, with belgian key layout (AZERTY like in France, but with some keys at other positions in the keyboard for example square brackets [] and braces{}). The locale is the following:

Code: Select all
$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:en
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=fr_BE.UTF-8
LC_TIME=fr_BE.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=fr_BE.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=fr_BE.UTF-8
LC_NAME=fr_BE.UTF-8
LC_ADDRESS=fr_BE.UTF-8
LC_TELEPHONE=fr_BE.UTF-8
LC_MEASUREMENT=fr_BE.UTF-8
LC_IDENTIFICATION=fr_BE.UTF-8
LC_ALL=



I use out-of the box Ubuntu with standard Unity.
Alix
CodeLite Curious
 
Posts: 8
Joined: Sun Nov 16, 2014 12:54 am

Re: CL 6.1 on Ubuntu 14.10, loses many keystrokes, unusable

Postby piebru57 » Sun Nov 16, 2014 2:14 pm

100% same Alix situation and behaviour here, so it seems a wx* only issue with some "normal" Ubuntu setups.

* Fresh, almost plain vanilla Ubuntu 14.10, default Unity DE, same issue by installing CL from repos or by using dpkg. I installed 14.10 some days ago, and I didn't mess up the system yet :)
* CL61 is the only app with this issue in my system.
* No CPU abnormal load or spikes (I7 4core 8GB RAM here).
* Same Ubuntu 14.10 64bit desktop as stock Live ISO in VMware Player does not suffer the issue (always US English language and Italian keyboard).
* System language is US English, system locale is Italy, keyboard layout is Italy.
* Removing ~/.codelite and restarting does not change the issue.
* I observed the project settings form suffer the same issue, and even more: often I'm able to select part of a field with the mouse, but not with keyboard, backspace and cancel often don't work at all inside any wx* input field (i.e. execution program arguments).

I just tested spawning CL and opening a new file tab: the problem persists as long there is also a workspace opened. After closing the workspace, key losses disappear even without restarting CL.

Code: Select all
$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=it_IT.UTF-8
LC_TIME=it_IT.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=it_IT.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=it_IT.UTF-8
LC_NAME=it_IT.UTF-8
LC_ADDRESS=it_IT.UTF-8
LC_TELEPHONE=it_IT.UTF-8
LC_MEASUREMENT=it_IT.UTF-8
LC_IDENTIFICATION=it_IT.UTF-8
LC_ALL=


Thanks David,
Piero
piebru57
CodeLite Enthusiast
 
Posts: 12
Joined: Sat Nov 15, 2014 1:16 pm

Next

Return to Help

Who is online

Users browsing this forum: No registered users and 7 guests