Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

CodeLite installation/troubleshooting forum
User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by eranif » Tue Aug 10, 2010 8:37 pm

When installing codelite using the apt-get / apttitude - you are NOT using the installers provided from this site. You are using the installers provided by Ubuntu itself.

You should either use the deb files provided by me from
https://sourceforge.net/projects/codeli ... b/download

or report to Ubuntu as a bug

Eran
Make sure you have read the HOW TO POST thread

midisa
CodeLite Enthusiast
Posts: 29
Joined: Tue Jun 15, 2010 7:25 am
Genuine User: Yes
IDE Question: C++
Location: Russia, Omsk
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by midisa » Thu Aug 12, 2010 8:57 am

after installing from .deb file, you program no starting. show error:

codelite: relocation error: /usr/lib/codelite/libpluginu.so: symbol _ZN13wxAuiNotebook7SetFontERK6wxFont, version WXU_2.8 not defined in file libwx_gtk2u_aui-2.8.so.0 with link time reference

please send this error to bug report ubuntu.

I tried various options to install and run your program.

same problem was Postgresql administrator.
I've completed this sequence of commands:


# Apt-get remove pgadmin3
(Package pgadmin3-data should remain)
# Apt-get install dpkg-dev
# Apt-get source pgadmin3
# Apt-get install debhelper libpq-dev libwxgtk2.8-dev libxml2-dev devscripts libxslt1-dev autotools-dev
# Cd pgadmin3-1.10.2
# Dpkg-buildpackage
# Dpkg-i ../pgadmin3_1.10.2-1_i386.deb

postgres admin program was run.

Maybe there is a similar solution for your program? Look at these teams that I said. I do not understand the meaning of these commands, but you can understand. Perhaps there is a link between the problem pgadmin and your program ...

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by eranif » Thu Aug 12, 2010 9:36 am

You need to be more specific about how did you install codelite.

I am using codelite under Ubuntu10.04/64 bit with no problems at all.

Eran
Make sure you have read the HOW TO POST thread

midisa
CodeLite Enthusiast
Posts: 29
Joined: Tue Jun 15, 2010 7:25 am
Genuine User: Yes
IDE Question: C++
Location: Russia, Omsk
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by midisa » Thu Aug 12, 2010 10:37 am

I install your program through. Deb file. The program does not run. Then delete your program sudo aptitude remove codelite. I opened the center applications. Install your program from the center applications. Your program does not start. Then delete your program. I'm trying to put it from source, but when I give the command make, receive an error message.

I do not understand the reason for the error. It just says error 1. I have attached the error message above.

I asked for help in the Russian forum. I was told to rearrange wxGTK. I moved the wxGTK from source files. Error remained.
All unchanged.

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by eranif » Thu Aug 12, 2010 3:55 pm

Hi,

In this forum we do not support installation through the "Synaptic Package Manager" the codelite suggested from there was not built by the codelite team.

You should either install the deb file from here:
1) Download: https://sourceforge.net/projects/codeli ... b/download
2) from the command line:

Code: Select all

sudo dpkg -i /path/to/codelite_2.6.0.4189-ubuntu0_amd64.deb
Try to start codelite - if it fails, try to compile codelite from sources. Follow the instruction in this post step-by-step:
http://codelite.org/forum/viewtopic.php ... rt=0#p4420

Eran
Make sure you have read the HOW TO POST thread

midisa
CodeLite Enthusiast
Posts: 29
Joined: Tue Jun 15, 2010 7:25 am
Genuine User: Yes
IDE Question: C++
Location: Russia, Omsk
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by midisa » Thu Aug 12, 2010 4:48 pm

1. I tried to install as you said. The program was installed. But the program was not run.
2. I previously served as a sequence of actions written on this page. Everything runs without errors to the command make. The make error. I previously reported.

What information to provide you to help me?

oleg
CodeLite Curious
Posts: 1
Joined: Thu Aug 19, 2010 3:45 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by oleg » Thu Aug 19, 2010 3:48 pm

I have the same error.
I installed via apt-get install, built from sources but again the same error...

10.04 x64

midisa
CodeLite Enthusiast
Posts: 29
Joined: Tue Jun 15, 2010 7:25 am
Genuine User: Yes
IDE Question: C++
Location: Russia, Omsk
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by midisa » Thu Aug 19, 2010 6:53 pm

oleg wrote:I have the same error.
I installed via apt-get install, built from sources but again the same error...
10.04 x64
I send bug report about this error:
https://bugs.launchpad.net/ubuntu/+bug/616629

I do not know English. If you know, to supplement the information my message. I do not understand what they ask me.
I am temporarily using NetBeans to deal with wxWidget.
I want to use CodeLite, but I can not run it on my computer.
Dear Eran, help us fix this problem. It must be a solution ...

midisa
CodeLite Enthusiast
Posts: 29
Joined: Tue Jun 15, 2010 7:25 am
Genuine User: Yes
IDE Question: C++
Location: Russia, Omsk
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by midisa » Fri Aug 20, 2010 9:22 am

midisa@midisa-desktop:~/codelite$ ./configure && make
Generating svninfo file...
Generating Makefile...
Generating sdk/codelite_indexer/Makefile...
Generating sdk/codelite_cppcheck/Makefile...
Generating Debugger/Makefile...
Generating Gizmos/Makefile...
Generating cscope/Makefile...
Generating Subversion2/Makefile...
Generating CodeFormatter/Makefile...
Generating Copyright/Makefile...
Generating UnitTestCPP/Makefile...
Generating ExternalTools/Makefile...
Generating SnipWiz/Makefile...
Generating wxformbuilder/Makefile...
Generating abbreviation/Makefile...
Generating SymbolView/Makefile...
Generating ContinuousBuild/Makefile...
Generating QmakePlugin/Makefile...
Generating cppchecker/Makefile...
./le_makerevision.sh
Generating svninfo file...
g++ -DON_64_BIT -O3 -DREGEXP_UNICODE -fPIC -shared -o ./lib/libwxsqlite3u.so Release_gcc_unicode/wxsqlite3.o Release_gcc_unicode/sqlite3.o -L./lib -L/usr/local/lib -pthread /usr/local/lib/libwx_gtk2u_richtext-2.8.a /usr/local/lib/libwx_gtk2u_aui-2.8.a /usr/local/lib/libwx_gtk2u_xrc-2.8.a /usr/local/lib/libwx_gtk2u_qa-2.8.a /usr/local/lib/libwx_gtk2u_html-2.8.a /usr/local/lib/libwx_gtk2u_adv-2.8.a /usr/local/lib/libwx_gtk2u_core-2.8.a /usr/local/lib/libwx_baseu_xml-2.8.a /usr/local/lib/libwx_baseu_net-2.8.a /usr/local/lib/libwx_baseu-2.8.a -pthread -L/usr/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lXinerama -lXxf86vm -lSM -lpng -ljpeg -ltiff -lexpat -lwxregexu-2.8 -lz -ldl -lm -pthread -L/usr/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
/usr/bin/ld: /usr/local/lib/libwx_baseu-2.8.a(baselib_datetime.o): relocation R_X86_64_32 against `wxDateTimeHolidaysModule::ms_classInfo' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libwx_baseu-2.8.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [SQLite] Error 1
midisa@midisa-desktop:~/codelite$

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Ubuntu 10.04 64bit and Codelite 2.5.3.4075 install

Post by eranif » Fri Aug 20, 2010 10:34 am

In order to build codelite, you need to have libwx compiled as shared libraries in Unicode and NOT 'static' (.a)

How did you install your wx libraries? Did you build it youself?

Eran
Make sure you have read the HOW TO POST thread

Post Reply