wxWidgets Libraries aui,html,core,net,xrc,xml,base not found during linking

General questions regarding the usage of CodeLite
ultrajunkie
CodeLite Curious
Posts: 7
Joined: Mon Mar 20, 2017 11:05 pm
Genuine User: Yes
IDE Question: C++
Contact:

wxWidgets Libraries aui,html,core,net,xrc,xml,base not found during linking

Post by ultrajunkie »

I have built the latest wxWidgets version 3.2.1 and try to rebuild one of my applications in debug mode using Codelite to see if the setup is (still) working.

What I find is that the linker searches for the following files:

wxmsw32u_auid
wxmsw32u_htmld
wxmsw32u_cored
wxmsw32u_netd
wxmsw32u_xrcd
wxmsw32u_xmld
wxmsw32u_based

while the libraries were named during compilation:

wxmsw32ud_aui
wxmsw32ud_html
wxmsw32ud_core
wxmsw32ud_net
wxmsw32ud_xrc
wxmsw32ud_xml
wxmsw32ud_base

This of course leads to file not found errors and linking fails. It seems to be an issue together with the latest version of Codelite (16.5.0) but I can't find any place where to change it. With the version 16.2.0 it compiles without errors.

Building the Release version works well because of the missing "d". Any ideas?

User avatar
eranif
CodeLite Plugin
Posts: 6310
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wxWidgets Libraries aui,html,core,net,xrc,xml,base not found during linking

Post by eranif »

This is a bug in our wx-config tool provided by CodeLite
How did you build your wxWidgets? (CMake... other methods?)

Make sure you have read the HOW TO POST thread
ultrajunkie
CodeLite Curious
Posts: 7
Joined: Mon Mar 20, 2017 11:05 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wxWidgets Libraries aui,html,core,net,xrc,xml,base not found during linking

Post by ultrajunkie »

I used the minGW32-make tool.

There seems to be also another bug: if I do not specify each lib separately the linker also searches for wxmsw32u(d)_qa which is not generated when building the libraries and only needed for VC as far as i could determine.

ultrajunkie
CodeLite Curious
Posts: 7
Joined: Mon Mar 20, 2017 11:05 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wxWidgets Libraries aui,html,core,net,xrc,xml,base not found during linking

Post by ultrajunkie »

We identifed the root cause, and asmwarrior is preparing a fix. As soon as it is tested, this thread can be closed :)

User avatar
eranif
CodeLite Plugin
Posts: 6310
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wxWidgets Libraries aui,html,core,net,xrc,xml,base not found during linking

Post by eranif »

FYI: I merged his fix

Make sure you have read the HOW TO POST thread
Post Reply