Autocompletion don't works. GNU/Linux compiled from Git Sources

General questions regarding the usage of CodeLite
Josz
CodeLite Curious
Posts: 1
Joined: Tue Oct 06, 2020 8:34 pm
Genuine User: Yes
IDE Question: C++
Contact:

Autocompletion don't works. GNU/Linux compiled from Git Sources

Post by Josz »

HI,
first of all, thank your for this marvelous IDE.

I got the last version (14.04) from git.

The compilation procedure was make following the next steps: (taken from README.md)

Code: Select all

  cd codelite
  mkdir build-release
  cd build-release
  cmake .. -DCMAKE_BUILD_TYPE=Release
  cmake --build . -j16
  sudo cmake --build . --target install 
Under settings-> Code Completion-> search paths, I have set

Code: Select all

/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/x86_64-pc-linux-gnu
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include/g++-v9/backward
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/include-fixed
/usr/include
/usr/include/linux/
But simply (after save || restart codelite) don't works, and I have not Idea why.

Please, someone so kind to help me?
Thanks in advance
User avatar
eranif
CodeLite Plugin
Posts: 6196
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Autocompletion don't works. GNU/Linux compiled from Git Sources

Post by eranif »

With recent versions of CodeLite, the code completion is based on clangd.
Did you configure your clangd properly? (plugins -> language server -> settings)
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
Posts: 6196
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Autocompletion don't works. GNU/Linux compiled from Git Sources

Post by eranif »

it is configured out of the box. at least with recent versions.
did you check the language server settings ? plugins -> language server
Make sure you have read the HOW TO POST thread
Post Reply