Moving to wxWidgets 2.9.5

Discussion about CodeLite development process and patches
User avatar
eranif
CodeLite Plugin
Posts: 5898
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Moving to wxWidgets 2.9.5

Post by eranif » Sat Jul 20, 2013 8:41 am

Hi,

Building codelite from git now requires wxWidgets 2.9.5

Windows developers who are using MinGW4.7.1-TDM (the default's codelite compiler) can use this installer:
http://sourceforge.net/projects/codelit ... e/download

Our Linux repositories were updated with the latest wx295 binaries:
http://codelite.org/LiteEditor/WxWidgets29Binaries#toc1

Note that running 'cmake' will fail if you have version < 2.9.5
The main reason for doing this is to have the latest version of wxStyledTextCtrl (mainly it restores some broken functionalities like colour disabled code blocks with grey colour, allow selecting single character with double click and others)

Eran
Make sure you have read the HOW TO POST thread